APNs not recognized/ UID mismatch

Problem

After renewing your APNs certificate, you are trying to upload it in the Mobile Device Manager Plus MSP Server and you get an error message "APNs not Recognized/ UID mismatch"

Cause

While renewing your APNs certificate, a new apple ID has been used. You are supposed to use the same Apple ID that you have used while creating APNs for the first time.

Resolution

Ensure that you renew the APNs certificate using the same Apple ID, if you do not know which Apple ID you have used, then you will have to create a new APNs certificate and enroll your mobile devices again for them to be managed.

Note: If you have more than one APNs certificate created using the same Apple ID, select the appropriate APNs certificate using the UID and then renew it. You can refer to the image below. It is recommended to enter information that can be used to identify the certificate to be renewed in the Notes section.

 

 APNs Renewal
APNs Renewal2
Applies to: APNs Renewal, APNs Expiry, Apple ID

Keywords: APNs, Apple ID, Renew Certificate, Mobile Device Management