网络路径未找到/ 发生扩展错误
问题
Endpoint Central 代理/分发服务器安装、补丁扫描、资产扫描和远程控制失败,错误信息为 - “网络路径未找到。”
原因
该错误会在以下情况显示,
- 客户端计算机关闭或无法访问
- 客户端计算机的网络适配器中未启用“Microsoft 网络的文件和打印机共享”。
- Microsoft 防火墙阻止了该进程。
- 第三方防火墙阻止了该进程。
- 客户端计算机上的管理共享(Admin$)可能被禁用。
注意:
- 本文所述的原因/解决方案基于我们在生产和客户环境中的经验。但仍可能存在一些未知原因。如果本文未能解决您的问题,且您拥有基于 Active Directory 的网络,您可以 使用启动脚本 自动化代理安装。
- 本文提供的解决方案将帮助您解决手动补丁和资产扫描过程中遇到的问题。但某些情况下,因各种原因可能会再次失败。建议您执行定期的 补丁 和 资产扫描。.
解决方案
您可以按以下方法解决该问题:
确保客户端计算机可访问
检查客户端计算机是否已开机且正常连接网络,以便安装代理/分发服务器并执行补丁扫描/远程控制/资产扫描等操作。同时确保您正确指定了计算机名称。以下步骤帮助您确认客户端机器的可访问性:
进入开始 > 运行 > 输入以“\\”开头的计算机名并按回车键
启用“Microsoft 网络的文件和打印机共享”
在所有客户端计算机上启用此功能,以执行代理或分发服务器安装、补丁扫描、资产扫描、远程控制等远程操作。
对于操作系统为 Windows 7 之前版本的计算机,执行以下步骤;
- 选择开始 --> 设置 --> 网络连接。
- 右键点击网络连接并选择属性。
- 在连接属性对话框中,选择常规标签。
- 选择“Microsoft 网络的文件和打印机共享”,点击确定。
- 如果找不到该选项,请点击安装按钮。
- 在网络组件类型中,选择服务并点击添加。
- 选择 Microsoft 网络的文件和打印机共享 并点击确定。
- 点击关闭以退出属性对话框。
对于操作系统为 Windows 7 的计算机,执行以下步骤;
- 选择开始 --> 控制面板。
- 选择 网络和 Internet
- 选择 网络和共享中心 并选择 更改高级共享设置
- 在 文件和打印机共享下 启用 打开文件和打印机共享
- 保存更改
在客户端计算机上启用管理共享(Admin$)
Endpoint Central 应用程序在触发代理/安装前会将代理/分发服务器二进制文件复制到客户端机器的 Admin$ 共享。因此,客户端机器必须启用 Admin$,以确保代理/分发服务器顺利安装。您需要编辑注册表以启用默认管理共享。
对于服务器:
- 点击开始,选择运行。
- 输入 regedit 在运行提示框内点击确定。
- 在注册表中导航至以下路径并将 REG_DWORD 值编辑为 '1'
注册表路径:HKEY_LOCAL_MACHINE 键:SYSTEM\CurrentControlSet\Services\LanManServer\Parameters 名称:AutoShareServer 数据类型:REG_DWORD 值:1
注意: 1. 如果在确切位置找不到该值(即不存在) - 无需添加新值。 需要重启计算机以使更改生效。.
对于 Windows Server 2008 R2: 如果您使用 Windows Server 2008 R2 域环境,可以通过启动脚本在客户端机器启用 Admin$。详情请参阅此 文档 。
对于工作站:
- 点击开始,选择运行。
- 输入 regedit 在运行提示框内点击确定。
- 在注册表中导航至以下路径并将 REG_DWORD 值编辑为 '1'
注册表路径:HKEY_LOCAL_MACHINE 键:SYSTEM\CurrentControlSet\Services\LanManServer\Parameters 名称:AutoShareWks 数据类型:REG_DWORD 值:1
注意: 如果在确切位置找不到该值(即不存在) - 无需添加新值。 需要重启计算机以使更改生效。
适用范围: 代理/分发服务器安装失败,Endpoint Central 代理/分发服务器安装,补丁扫描失败,资产扫描失败
关键词: 代理/分发服务器安装,Endpoint Central 代理/分发服务器安装失败,补丁扫描失败,资产扫描失败,安装失败,发生扩展错误。