Entra ID OAuth 错误故障排除
错误 - OAuth 已移除
问题描述:
OAuth 配置已从中央服务器移除。
原因:
当之前配置的 Azure OAuth 凭据被删除或在中央服务器上不再可用时,会发生此情况。
解决步骤:
- 点击配置 Azure OAuth,将弹出窗口。

- 输入客户端 ID 和客户端密钥,然后配置 OAuth。
- 您将被重定向到 Azure 门户进行身份验证。
- 域身份验证完成,同步将继续。
错误 - 重新认证
问题描述:
身份验证会话已过期或失败,需要重新认证。
原因:
当 OAuth 令牌无效、过期或被 Azure AD 拒绝时,通常由于会话超时或手动撤销,会出现此问题。
解决步骤:
- 点击重新认证后。
- 您将被重定向到 Azure 门户进行身份验证。
- 域身份验证完成,同步将继续。
错误 - 无效的 OAuth 客户端密钥。
问题描述:
提供的 OAuth 客户端密钥不正确或无效。
原因:
当在 Azure OAuth 配置中使用了错误的客户端密钥时,会导致身份验证失败。
解决步骤:
- 点击无效的 OAuth 客户端密钥,将显示修改 OAuth 详细信息。
- 输入正确的客户端密钥并继续进行身份验证(点击修改)。

- 点击重新认证,您将被重定向到 Azure 门户进行身份验证。