问题

您尝试安装或卸载与 Ms Office 相关的补丁,但失败并显示以下任一错误:

  • 17031-无效基线(Windows Installer)
  • 17302-应用补丁(MSoCache)
  • 17025-补丁已安装(文件版本已更新)
  • 17028-未安装包含补丁的产品 - 已安装 / 升级代码缺失。
  • 17044-安装程序无法运行此软件包的检测。

原因

这可能是由于安装程序文件缺失导致的。MSI 文件被删除可能是以下任一原因所致:

  • 您可能因空间限制删除了 MSI 文件。
  • 第三方清理工具可能已损坏安装程序文件。
  • 安装杀毒软件可能导致文件被删除。
  • 机器上可能存在卸载后旧版 Office 的注册表项。

解决方案

下面是一些排查该问题的方法:

您机器上所有 Office 补丁均出现上述错误

  1. 如果出现错误的 Office 版本 不被 机器使用,则请通过以下路径检查这些机器上是否存在与该 Office 版本相关的注册表项: 注册表编辑器 > HKEY_LOCAL_MACHINE\SOFTWARE > 点击 F3 并搜索相关注册表项。
    • 如果存在与该 Office 版本相关的不必要的注册表项,请删除它们,重新扫描机器并检查结果。(注:我们的 Office 检测逻辑基于注册表项和值,只要机器中存在任何 Office 注册表项,系统就会检测到相应 Office 版本的最新更新缺失)。
    • 若无注册表项存在,请联系支持团队并提供受影响机器的代理日志以便详细分析。
  2. 如果出现错误的 Office 版本 如果该 Office 版本 被机器使用,问题很可能与环境有关。某些 Office 相关的安装文件可能已损坏或丢失。如果是这种情况,手动安装更新也可能因相同错误失败,请尝试在机器上手动安装任意更新并观察结果。如果手动安装也失败,请执行以下操作:
    • 检查 %temp% 目录下的微软日志以查找问题原因。
    • 尝试修复 Office 应用程序,然后重新尝试安装。
    • 如果问题依旧,卸载并重装 Office 应用程序。
    • 若问题仍未解决,请联系供应商进行问题的最终分析。

只有某个特定 Office 补丁

  1. 如果出现错误的 Office 版本 不被 机器使用,则请通过以下路径检查这些机器上是否存在与该 Office 版本相关的注册表项: 注册表编辑器 > HKEY_LOCAL_MACHINE\SOFTWARE > 点击 F3 并搜索相关注册表项。
    • 如果存在与该 Office 版本相关的不必要的注册表项,请删除它们,重新扫描机器并检查结果。(注:我们的 Office 检测逻辑基于注册表项和值,只要机器中存在任何 Office 注册表项,系统就会检测到相应 Office 版本的最新更新缺失)。
    • 若无注册表项存在,请联系支持团队并提供受影响机器的代理日志以便详细分析。
  2. 如果出现错误的 Office 版本 如果该 Office 版本 在机器中出现问题,请联系支持团队并提供受影响机器的代理日志以便详细分析。

适用范围: 补丁部署、补丁安装失败、补丁安装错误、补丁错误

关键词: 补丁安装、补丁管理、补丁部署错误、补丁安装失败

其他知识库文章24/5 支持

支持时间为每周五天(周一至周五),每天 24 小时,节假日除外(美国及印度公共假期)。

电话:+1-888-720-9500
邮箱: msp-endpointcentral-support@manageengine.com

联系我们

  • 加入 Endpoint Central 社区,立即获取您的问题答案,注册我们的 论坛
  • 关注桌面管理最新动态,关注我们的 Twitter.
  • 通过我们的 博客.

知识库