补丁安装失败 - “错误代码:-2146498511

问题

当您尝试安装 Windows 补丁,尤其是累积更新时,您会收到以下错误信息 “未知错误代码:-2146498511。

此外,您还会在 CBS.log 中收到类似以下的错误消息:
存储损坏,包的清单缺失:{Missing_Package}
无法解析包 {Missing_Package} [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
因包 {Missing_Package} 标记存储损坏标志 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
解析包失败 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
获取下一个重新评估包失败 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
执行执行链失败。 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
处理单阶段执行失败。 [HRESULT = 0x800f0831 - CBS_E_STORE_CORRUPTION]
WER:为包生成故障报告:{failed_package} 状态:0x800f0831,故障来源:执行,起始状态:已阶段,目标状态:已安装,客户端ID:DISM Package Manager Provider

原因

此问题发生是因为无法安装的更新需要之前更新包的清单。

解决方案

  • 搜索并部署 {Missing_Package}/{Failed_Package}。
  • 重启系统,然后重新部署失败的补丁。

如果 {Missing_Package}/{Failed_Package} 已被替代,则请按照以下步骤操作:

  • 访问 Microsoft Update Catalog。
  • 在搜索框中输入 {Missing_Package}/{Failed_Package} 或两者的包 ID。
  • 下载该包并安装。

如果即使按照上述解决方案操作后仍收到“安装失败”消息,请联系技术支持。

受信赖的