更新 NAT 设置或导入证书时出错

本文档解释了在更新 NAT FQDN 以及导入新证书时,由于 SAN 不匹配导致代理通信失败的问题,以及如何通过在证书中同时包含旧 FQDN 和新 FQDN 来避免该问题。

问题

在 Endpoint Central 中更新 NAT(完全限定域名)并导入新证书时, 代理可能无法与服务器通信,导致受信任的通信中断。

注意:此情况仅适用于在 Endpoint Central 服务器导入企业或第三方证书时。

原因

Endpoint Central 强制要求 受信任的通信 在服务器和代理之间,需进行证书验证。

如果导入的新证书仅包含 新的 NAT FQDN,仍尝试使用 旧的 NAT FQDN 连接的代理将出现 主题备用名称(SAN)不匹配。该不匹配导致证书验证失败,进而导致代理与服务器之间的通信中断。

解决方案

为确保 NAT FQDN 更新的顺利和安全,请遵循以下步骤:

  1. 生成一个证书,在主题备用名称中同时包含新 NAT 地址和旧 NAT 地址。
  2. 将证书导入 Endpoint Central 服务器。
  3. 使用新的 FQDN 更新 NAT 地址。
  4. 代理与 Endpoint Central 服务器通信后,NAT 设置将更新给代理。代理随后将使用新的 FQDN 与 Endpoint Central 建立通信。
  5. 一旦所有代理成功连接到 Endpoint Central 服务器,您可以导入仅包含新 FQDN 的主题备用名称的新证书。

该过程确保代理在过渡期间能够继续通信且不会出现验证错误。

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