排查 Endpoint Central 与 SDP/AE 之间的集成问题

连接问题

原因

  • SDP/AE 服务器未运行,或其详细信息(IP、端口、协议)不正确。
  • 防火墙或网络规则阻止了 Endpoint Central 与 SDP/AE 服务器之间的通信。

验证步骤

  1. 检查 Endpoint Central 中的服务器详细信息:
    转到 Admin > Integrations > ServiceDesk Plus Settings,确认 SDP/AE 服务器的主机名/IP、端口和协议是否正确输入。
  2. 确认 SDP/AE 服务器正在运行:
    在安装 SDP/AE 服务器的机器上,打开服务控制台,找到 SDP/AE 服务,如果已停止则启动。
  3. 测试基本网络连接:
    From the Endpoint Central server’s command prompt, run: ping <SDP-Server-IP>. If ping fails, verify the SDP/AE server’s network availability.
  4. 通过 Telnet 检查端口可访问性:
    Run: telnet <SDP-Server-IP> <port>. If Telnet fails, adjust firewall settings on both servers to allow the required ports (e.g., 8080).

解决方案

  • 在 Endpoint Central 的集成设置中纠正无效的服务器详细信息。
  • 确保 SDP/AE 服务器正在运行。
  • 调整防火墙配置以允许所需端口的流量。
  • 进行更改后,在 Endpoint Central 中重新验证集成。

API 密钥无效问题

原因

  • API 密钥已过期或不再有效。
  • API 密钥在 SDP/AE 中已重新生成,但未在 Endpoint Central 中更新。
  • 与密钥关联的技术人员被移除或丧失了管理员权限。

前提条件

您必须拥有 SDP/AE 管理员权限才能生成和维护有效的 API 密钥。

解决方案

您需要以管理员权限生成新的身份验证密钥,并在 Endpoint Central 集成页面中指定该密钥。

  1. 生成身份验证密钥
    您可以在 Endpoint Central 控制台或 SDP/AE 控制台生成身份验证密钥。

    从 EC 服务器

    1. 转到 Admin > Integrations > ServiceDesk Plus Settings 在 Endpoint Central 中。
    2. 点击 Regenerate.
    3. 使用管理员凭据登录 SDP 服务器。
    4. 点击 生成身份验证令牌,指定过期日期,然后点击 Generate.
    5. 复制生成的身份验证密钥。

    从 SDP 服务器

    1. 使用管理员凭据登录 ServiceDesk Plus。
    2. 转到 Personalize 页面顶部的标签。
    3. 点击 API 密钥生成.
    4. 指定过期日期并生成 API 密钥。
    5. 复制生成的身份验证密钥。
  2. 在 Endpoint Central 中粘贴 API 密钥
    1. 登录 Endpoint Central Web 控制台。
    2. 点击 Admin 选项卡。
    3. Integrations 部分中,点击 ServiceDesk Plus Settings.
    4. 如有必要,修改 ServiceDesk Plus 服务器详细信息。
    5. 输入新生成的 API 密钥并保存设置。

SSL 证书问题

原因

    • ServiceDesk Plus 服务器的 SSL 证书无效、已过期或不匹配。
    • 集成配置未正确信任 ServiceDesk Plus 服务器的 SSL 证书。

    解决方案

      • 确认 ServiceDesk Plus 服务器上的 SSL 证书有效、配置正确且未过期。
      • 在 Endpoint Central 中重新配置集成,将正确的 SSL 证书导入到 Endpoint Central 的密钥库。

      受以下机构信任