补丁配置失败 - “从服务器下载补丁时出现问题”

问题

您正在尝试在网络计算机上部署补丁。然而,补丁部署状态显示消息 - “从服务器下载补丁时出现问题”。

原因

如果驻留在客户端机器上的代理无法从 Endpoint Central 服务器下载特定补丁,您将遇到此错误。可能的原因有:

  • 如果您最近将补丁存储目录更改到新位置,但未能将补丁从先前目录复制到新位置。 (或)
  • 如果您已从补丁存储中删除了补丁。(或)
  • 如果您选择了以下选项 即使某些补丁无法下载,也继续部署,如下所示

已选择部署规则

解决方案

您可以通过以下方法解决此问题:

  • 将补丁从先前目录复制到新位置。
  • 在目标系统上重新部署补丁。
  • 取消选中/取消选择以下选项 即使某些补丁无法下载,也继续部署,如下所示

取消选择部署规则

 

错误代码解决方案
12002,12007,12019,12029,12030,12175  确保代理能够从中央和分发服务器访问。
403 确保将厂商 URL 加入白名单。
404 在控制台中,检查下载补丁 -> 上传补丁中的所需补丁。

如果执行上述步骤后问题仍然存在,请联系 endpointcentral-support@manageengine.com 并附上相关日志文件以获取进一步的帮助。

受信赖的