Microsoft Office更新错误
问题
您试图安装或卸载与Ms Office相关的补丁,但失败了并提示以下错误:
- 17031-无效的基线(Windows安装程序)
- 17302-正在应用补丁(MSoCache)
- 17025-补丁已经安装(文件版本已更新)
- 17028-包含的补丁没有要安装的产品-已经安装/升级代码缺失
- 17044-安装程序无法运行此包的检测
原因
这可能是由于缺少安装程序文件。MSI文件可能会因下列原因而被删除:
- 您可能由于空间限制而删除了MSI文件
- 第三方清理工具可能损坏了安装程序文件
- 安装杀毒软件可能导致删除文件
解决方案
以下是解决问题的一些方法:
- 检查您系统中的ShellUi.Mst
ShellUI.Mst是一个与Windows操作系统的MSOffice相关联的文件。如果Windows由于上述原因,不能正确加载shellui.mst文件,解决方法如下:
- 首先查看安装程序文件是否在此路径中: C:\Windows\Installer\{OfficeproductID}\ShellUI.MST
- 如果该文件在您的机器中不可用,补丁安装可能会失败,并提示office安装程序错误代码
- 您可以从其他与缺失文件类似的机器上获取此文件
- 使用OpUtils.vbs故障排除:
Oputil.vbs是一个脚本,帮助检测、诊断和故障排除问题。也用于恢复文件。
使用OpUtils.vbs故障排除,步骤如下:
- 从此链接下载zip文件。
- 解压zip文件并获取OpUtils.vbs文件到任意位置。
- 以管理员身份运行命令提示符,并导航到文件OpUtils.vbs保存的文件夹下。
- 运行命令:cscript OpUtil.vbs repair。
这将解决一些与office相关的缓存问题。这也将在系统中安装缺失的补丁。
- 使用“恢复安装程序”文件恢复安装程序文件
一些c:\windows\installer文件夹中缺失的安装程序MSI文件可以通过备份计算机或从具有类似软件架构的其他计算机进行恢复。
- 打开此链接
- 下载Restore-InstallerFiles.ps1文件
- 进入文件下载的位置,并基于您找回数据的备份模式执行以下命令:
- 如果您想将安装程序文件从一台或多台计算机恢复到受影响的计算机:.\Restore-InstallerFiles -SourceMachine "Machine1", "Machine2", "Machine3";
- 如果您想从本地机器本身存在的安装程序文件夹中恢复安装程序文件:.\Restore-InstallerFiles -SourceFolder "D:\InstallerFiles", "E:\InstallerFiles", "\\MachineX\D$\MSI Files";
- 如果您想连同检索文件的日志恢复所有的文件:.\Restore-InstallerFiles -SourceFolder "D:\InstallerFiles", "E:\InstallerFiles", "D:\InstallerFiles2" -LogFile "D:\Log.txt";
- 使用Roi扫描来(Robust Office Inventory Scan)扫描您的系统
它是通过下载vbs脚本执行的资产清单扫描。该脚本扫描您的机器以找出缺失的补丁。创建一个日志文件,用于确定缺失的MSI和MSP文件。
扫描机器并找到缺失的补丁,步骤如下:
- 点击这里下载脚本。您可以点击微软链接获得更多关于RoiScan.vbs的信息。
- 从上述链接获取ROiScan.vbs文件并运行命令:cscript RoiScan.vbs
- 这将扫描整个机器并查找相关数据。所有关于RoiScan的日志都可以在C:\Users\Administrator\AppData\Local\Temp\machine_name-RoiScan.log和 C:\Users\Administrator\AppData\Local\Temp\machine_name-RoiScan.xml中找到。
如果在执行了所有这些步骤之后,补丁仍然失败,卸载并重新安装Ms Office来解决这个问题。